Risultati da 1 a 6 di 6

Discussione: come posso cambiare l'IP del DHCP in XP Pro ?

  1. Predefinito come posso cambiare l'IP del DHCP in XP Pro ?

    Salve,come dice il titolo,ho necessità di cambiare ip al dhcp in xppro,ma da connessioni di rete,protocollo tcp/ip mi lascia cambiare gateway ed altre cose e non quella.Anche le ricerche con google non hanno sortito l'effetto sperato.Qualcuno ha idea di come fare?

  2. #2

  3. Predefinito

    Citazione Originariamente Scritto da arturo Visualizza Messaggio

    Stai facendo confusione tra gli harwdare e i software.

    A cosa vuoi cambiare l'IP e perchè?
    Ho bisogno di cambiare l'ip del server dhcp,perchè questo xppro è su macchina virtuale(virtualbox)e lo volevo far connettere.Andando su connessioni di rete,tcp/ip ho cambiato il default gateway e ho messo l'ip del router che ho installato sul computer,ma l'ip del computer ,che viene assegnato dal dhcp non mi permette di navigare,visto che prende l'ip da un server dhcp che non è il mio router.Dovrei quindi cambiarlo,per poter navigare.Virtualbox usa il NAT,che dovrebbe andare bene,perchè con le distro linux virtualizzate riesco a navigare,con NAT e cambiando nameserver ,dandogli l'ip del router.Spero di essermi spiegato abbastanza bene,purtroppo le spiegazioni non sono mai state il mio forte.

  4. Predefinito

    Il DHCP non ha un IP proprio, maximus, ma si limita ad assegnarne uno a ciascuna periferica connessa e abilitata a riceverlo.
    Casomai esistono l'IP del router su cui gira il server DHCP - IP che coincide col Gateway da definire in Connessioni di Rete se si sceglie la procedura manuale - e il range (intervallo) di IP da assegnare. Due concetti molto diversi rispetto a quanto da te richiesto, quindi.
    Oltretutto, non credo che tutto questo vada modificato per connettere una macchina virtuale: dalle Connessioni di Rete di XP Guest devi abilitare l'ottenimento in automatico di IP e DNS, dalle opzioni della macchina virtuale la connessione tramite NAT.
    Con questa procedura mi sono sempre connesso senza problemi, mi sorge solo il dubbio che tu abbia installato un firewall software sul sistema operativo Guest

    http://forum.spreamedia.it/showthrea...light=firewall

    e che tutto dipenda da questo inconveniente.
    Ultima modifica di Giovenale; 31-12-08 alle 00:47
    "Lazio, Bacco e Venere fanno l'uomo cenere. Ma Lazio, Bacco e Venere fanno l'uomo" (liberamente rielaborata da un verso dei Carmina Burana)

  5. Predefinito

    Citazione Originariamente Scritto da Giovenale Visualizza Messaggio
    Il DHCP non ha un IP proprio, maximus, ma si limita ad assegnarne uno a ciascuna periferica connessa e abilitata a riceverlo.
    Casomai esistono l'IP del router su cui gira il server DHCP - IP che coincide col Gateway da definire in Connessioni di Rete se si sceglie la procedura manuale - e il range (intervallo) di IP da assegnare. Due concetti molto diversi rispetto a quanto da te richiesto, quindi.
    Oltretutto, non credo che tutto questo vada modificato per connettere una macchina virtuale: dalle Connessioni di Rete di XP Guest devi abilitare l'ottenimento in automatico di IP e DNS, dalle opzioni della macchina virtuale la connessione tramite NAT.
    Con questa procedura mi sono sempre connesso senza problemi, mi sorge solo il dubbio che tu abbia installato un firewall software sul sistema operativo Guest

    http://forum.spreamedia.it/showthrea...light=firewall

    e che tutto dipenda da questo inconveniente.
    Ciao Giovenale,sì,è quello che volevo dire io,l'ip del router che fa anche da server dhcp.Il firewall l'ho installato,sì,dovendo andare su internet pensavo fosse indispensabile per la protezione.Ho anche installato avira,non si sa mai.Per la cronaca il firewall è outpost free edition,vecchiotto ma a me è sempre andato alla grande.Devo disattivarlo?Anche dopo aver assegnato come gateway predefinito il mio router,l'ip della macchina virtuale è 10.0.2.15,essendo il mio router un netgear mi dovrebbe dare un indirizzo nel range 192.168 etc,se non sbaglio.Ho anche attivato l'opzione ottieni indirizzo ip automaticamente.Infatti,l'ip del server dhcp anche dopo aver settato come gateway predefinito il mio router netgear,risulta essere 10.0.2.2,chiaramente non un router netgear,visto che io non gli ho cambiato l'ip.
    Ultima modifica di maximus; 31-12-08 alle 11:41 Motivo: aggiunta info e correzioni

  6. Predefinito

    E' con immenso piacere che annuncio che il problema è stato risolto.Ho avuto un'ispirazione e anche se avevo disattivato Windows firewall e Centro di sicurezza da pannello di controllo,outpost firewall mi dava il firewall di Windows come connesso,allora ho caricato xp antispy sulla macchina virtuale e li ho disattivati da lì,poi ho inserito su Server Wins l'ip del mio router.Non ho purtroppo provato queste due cose da sole,quindi non so se ne bastava anche una sola.Comunque,funziona,non sto scrivendo dalla macchina virtuale solo perchè non ho ancora installato keepass sulla stessa,e la password di linuxpro è lungotta .Di nuovo grazie a tutti

Segnalibri

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •